Betsy и Xfce 4.12: обретение

Алексей Федорчук

Пару дней назад мы видели, что в собственно Linux Mint, что на кодовой базе Ubuntu, включить поддержку новой версии Xfce, 4.12, — проще пареной репы. А вот в будущей Betsy, RC-версии которой можно ждать со дня на день, всё на первый взгляд не так однозначно.

Самостоятельной редакции LMDE 2 с Xfce в настоящее время нет и, судя по всему, в обозримом будущем не предвидится. Любителям этого десктопа Клемент Лефевр рекомендует устанавливать его из официальных репозиториев Debian. Однако вот беда — и в ветке testing, которая скоро превратится в Debian 8 Jessie, и даже в Sid можно обнаружить только Xfce 4.10.1. Так что за последним релизом этой среды придётся лезть в ветку exprimental, что может вызвать некоторые опасения.

Однако практика показывает, что в этом нет ничего ни сложного, ни, тем более, страшного. И заполучить Xfce 4.12 можно, например, таким образом:

Для начала внести в файл /etc/apt/sources.list.d/official-package-repositories.list строку

deb http://ftp.ru.debian.org/debian/ experimental main

Затем выполнить обновление кеша командой

$ apt update

И с помощью команды

$ apt policy | grep experimental

убедиться, что репозиторий экспериментальной ветки получил минимальный приоритет:

   1 http://ftp.ru.debian.org/debian/ experimental/main i386 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=main
   1 http://ftp.ru.debian.org/debian/ experimental/main amd64 Packages
     release o=Debian,a=experimental,n=experimental,l=Debian,c=main

Цифра 1 показывает, что пакеты из экспериментального репозитория не будут участвовать ни в каких обновлениях системы — ни через apt upgrade, ни посредством Менеджера обновлений. Что, однако, не помешает нам сначала убедиться в доступности метапакета xfce4 нужной версии:

$ apt show -t experimental xfce4
Пакет: xfce4
Состояние: установлен
Автоматически установлен: нет
Версия: 4.12
...

А затем и установить его:

$ apt install -t experimental xfce4

Теперь для проверки остаётся только завершить сеанс Cinnamon (если использовалась эта среда) и в приглашении MDM выбрать пункт, маркированный как xf Сеанс, что даст нам такую картину:

xfce-and-betsy_001
Назвать это полноценной средой Xfce пока нельзя: в ней нет ни одного штатного приложения, ни одного плагина. Но это дело легко поправимое, как будет показано в следующей заметке.

Betsy и Xfce 4.12: обретение: 2 комментария

  1. А когда, простите, будет следующая заметка?

Оставить комментарий

Перейти к верхней панели