LM vs LMDE: пакеты и версии, или конец одной легенды

Алексей Федорчук

Принято считать, что Debian — дистрибутив очень консервативный, и включает в себя версии пакетов времён Скобелева и присоединения Коканда. Тогда как Ubuntu, напротив, полагают дистрибутивом фронтирным, содержащим самые современные релизы тех же пакетов. И молчаливо подразумевается, что это различие наследуется дистрибутивами проекта Mint.

Со вторым тезисом не поспоришь — все базовые компоненты и Linux Mint, и LMDE напрямую берутся из репозиториев Ubuntu и Debian, соответственно. А вот тезис первый требует проверки. Каковая и была произведена для релизов Linux Mint 17.2 Rafaela и LMDE 2 Betsy, по состоянию их официальных репозиториев на 14.07.2015.

Разумеется, сравнивать версии всех пакетов — задача непосильная (да и ненужная). Поэтому в качестве объектов сравнения были выбраны представители трёх групп:

  • пакеты, в той или иной мере используемые почти всеми применителями;
  • пакеты, используемые лично мной, и за версиями которых я слежу
  • пакеты, требуемые для всякого рода верстальных задач.

Список последних взят из комментария Юрия aka Георгий Виноградов к одному из набросков к книге Моя дорогая Betsy. Собственно, этот комментарий, а также личная переписка с его автором, и послужили непосредственным поводом к проведению данного сравнения. Результаты его приведены в таблице.

Пакеты Rafaela Betsy
Для всех
libreoffice 4.4.3~rc2-0ubuntu1~trusty1 4.3.3-2+deb8u1
firefox 39.0+build5-0ubuntu0.14.04.1 38.0.1~linuxmint1+betsy
pidgin 2.10.9-0ubuntu3.2 2.10.11-1
Для меня
zsh 5.0.2-3ubuntu6 5.0.7-5
geany 1.23.1+dfsg-1 1.24.1+dfsg-1
gthumb 3:3.3.1.is.3.2.7-0ubuntu1 3:3.3.1-2+b2
shutter 0.90.1-0ubuntu1.1 0.92-0.1
calibre 1.25.0+dfsg-1build1 2.5.0+dfsg-1
Для вёрстки
inkscape 0.91.0+47~ubuntu14.04.1 1.4.4+dfsg1-2+b1
scribus 1.4.2.dfsg+r18267-1ubuntu2 1.4.4+dfsg1-2+b1
krita 2.8.5-0ubuntu6~ubuntu14.04~ppa1 2.8.5+dfsg-1+b2
musescore 1.3+dfsg-1 1.3+dfsg1-0.1

Тот самый случай, когда комментарии, как говорится, излишни: за буквально двумя исключениями, пакеты в Betsy представлены версиями, идентичными таковым в Rafaela, или более новыми. Особенно разителен (для меня) пример с Calibre: это один из тех редких в наши дни случаев, когда смена номера (от 1.X до 2.X) сопровождалась существенным расширением функционала.

Предвижу возражение: Rafaela основана на пакетной базе Ubuntu 14.04 LTS, вышедшей больше года назад, Betsy же — на базе Debian 8 Jessie, релиз которой состоялся 26.04.2015. А поскольку базовые компоненты обоих родительских дистрибутивов обычно «мажорно» не обновляются, естественно, что версии пакетов в LM на текущий момент будут более старыми. А вот если взять пакеты из PPA — там-то и будет самый «свежак».

Возражение с негодованием отметается. Во-первых, в основе Rafaela лежит корректирующий релиз Ubuntu 14.04.2, датируемый 19.02.2015 — времени подновить пакеты, по крайнгей мере существенно «обогащённые» возможностями, было достаточно. А во-вторых, в распоряжении LMDE имеются и официальные репозитории Debian веток, отличных от stable, которые и правомерно напрямую сравнивать с пакетами из PPA. И которые чисто технически подключить и использовать проще, чем рыскать по Launchpad.net в поисках отдельных «репок». Которые, кстати, тоже могут быть задействованы в LMDE, но это — отдельная тема.

LM vs LMDE: пакеты и версии, или конец одной легенды: 4 комментария

  1. Для сравнения, порты на FreeBSD:

    % pkg info -x libreoffice
    libreoffice-4.3.7
    ru-libreoffice-4.3.7
    % pkg info -x firefox
    firefox-38.0.6,1

    pidgin-2.10.11
    zsh-5.0.8_2
    geany-1.24.1
    gthumb-3.4.0
    shutter-0.93.1_1
    calibre-1.48.0_7
    inkscape-0.91_2
    scribus-1.4.5
    krita — отсутствует

  2. iZEN, всё правильно: версии пакетов зависят не от системы/дистра, а от радивости/нерадивости майнтайнера :)

Оставить комментарий

Перейти к верхней панели