Flash: как это делается в Ubuntu’ах

Алексей Федорчук

Отовсюду мы слышим стоны.
Со всех концов нашей обширной страны взывают о помощи.
Мы должны протянуть руку помощи, и мы её протянем.
И.Ильф и Е.Петров, Двенадцать стульев

Вот уже много лет мне казалось, что проблема воспроизводства flash-роликов в Linux’ах потеряла свою актуальность, и по трём причинам.

Первая из них — в понимании народом той истины, что большинство контента, представляемого через flash, являет собой знаменитый «продукт вторичный», о котором говорил известный антисоветский писатель Владимир Войнович. Вторая — большая часть этого контента (как и вполне качественного) нынче может быть выведена через HTML5. Ну а третья — мне казалось, что те, кому действительно нужен flash-контент, не воспроизводимый никаким другим способом, давно уже знают, как включается соответствующая поддержка в их любимых дистрибутивах.

Однако оказалось, что стоны, которые неслись лет 10 назад со всех форумов Рунета, не утихли до сих пор. В том числе и с ресурсов Ubuntu’евой направленности. И потому надо, откинув снобизм, протянуть руку помощи. Тем более, что оказалось: flash нужна не только для просмотра порнухи и каналов российского телевидения, но иногда и для вполне полезных вещей.

Вот, для примера. Давеча собирал я материалы к продолжению своего очерка моей Cintu. Надо сказать, что включить поддержку flashplayer’а в не непросто. Во-первых, надо выполнить тяжкую работу по определению точного имени нужного пакета. Что делается ужасной командой

$ apt se flashplayer

Вывод её будет следующим:

Сортировка… Готово
Полнотекстовый поиск… Готово
flashplugin-nonfree-extrasound/xenial,now 0.0.svn2431-5ubuntu1 amd64
  Библиотека поддержки платформы Adobe Flash Player для Esound и OSS.

После чего найденный пакет должен быть установлен (столь же сложным способом):

$ sudo apt in flashplugin-nonfree-extrasound

А по завершении процедуры надо будет перезапустить текущие браузеры (если в момент установки они работали). И всё: в любом из них отныне flash будет воспроизводиться без всяких проблем.

Нет, на счёт любого я, конечно, чуток преувеличил: сказанное имеет силу для Firefox и клона его, Pale Moon’а. На Opera это не окажет никакого действия. Почему? Не разбирался, ибо Opera у меня других целей. А с Chrome и Chromium не проверял, потому как они у меня вообще не живут.

Моя Cintu в базовой своей части целиком основана на репозиториях Ubuntu 16.04 LTS. И потому всё сказанное применимо ик материнской системе, и ко всем её отпрысками, типа Xubuntu, Kubuntu etc. Разве что в них придётся дополнительно потрудиться, и субкоманды утилиты apt давать в полном виде: search вместо se, и install вместо in.

Подозреваю, что и в большинстве более иных дистрибутивов дело обстоит точно так же. Разве что имя пакет, обеспечивающего поддержку flash, будет отличаться.

Flash: как это делается в Ubuntu’ах: 20 комментариев

  1. Так вот практика и показывает, что это не самый лучший способ.
    Обычно во всех дистрах (кроме, разве что, Slackware) проще всего пользоваться штатным пакетным менеджером.

  2. В Netrunner 16 проблемы возникали как раз с попытками штатным образом обновить на последнюю версию :-)

  3. Netrunner 16, если эклер не подводит, основан на Ubuntu 15.04. Так что штатного способа обновления именно на последнюю версию в нём, скорее всего, просто нет: бэкпортированием на все не LTS-версии в Canonical не злоупотребляют. А если обновлять из подключённого репозитория более высокой версии — да, проблемы очень не исключены.
    Но это уже несколько за рамками темы. В данном случае речь идёт о банальном включении флеши той версии, которая соответствует версии дистрибутива.

  4. Для работы флешплеера достаточно было установить один пакет: adobe-flashplugin.

  5. К сожалению проверкой актуальности версии злоупотребляет Mozilla :-( Это естественно преодолимо, но по сумме телодвижений привлекательность штатного пакетного менеджера как минимум спорна. Что же касается актуальности, то я очень сомневаюсь, что кто-то будет переписывать на HTML5 огромный массив интерактивных схем работы экзотических железок. Фактически становится недоступной справочная информации задуманная как долгоиграющая. Что касается «продукта вторичного» то и в абсолютном и в процентном отношении его существенно больше в текстовом формате. По поводу третьего пункта — знают старики инженеры, которые вероятно и без схем знают как устроено старое железо. Т.е. мы теряем преемственность в областях, которые развиваются не так быстро как компьютеры, например, в оптике и механике.

  6. vita, а вот мне apt тоже велел один пакет установить — но с другим именем, flashplugin-nonfree-extrasound. А комментом выше поступило предложение на pepperflashplugin-nonfree.
    И, повторяю, есть большое подозрение, что все эти способы сработают.
    PS Таня, Вы песенки Охрименко и Co заценили?
    ИМХО, это важнее, чем всё, что я написал о флешах и многом другом :)

  7. Алексей, песенки Охрименко услышала впервые. До прочтения Вашего очерка о существовании этого автора-песенника не знала. Спасибо Вам за новое имя.
    С интересом послушала передачу о нём. В остроумии Вашему тёзке не откажешь. Но песенки, исполненные речитативом на одну мелодию, большого впечатления не произвели. Главное в них, видимо, содержание.

  8. Serg Bormant, а эту тему предлагаю Вам обсудить с RWPBB. Сергей, Володя! Если найдёте точки пересечения интересов — буду считать, что эту заметку сочинил не зря :)

  9. vita, самое смешное, что его имя мало кто знал даже в те времена, когда «Батальонного разведчика» можно было услышать в каждой подмосковной электричке. А про «Гамлета с пистолетом» с его комсоставской рапирой распевали в каждом втором ташкентском дворе :)
    > Главное в них, видимо, содержание.
    Конечно. Как и во всей авторской песне вообще.

  10. Информация об установке Flash несколько не достоверна.
    flashplugin-nonfree-extrasound
    Информация о пакете — Это открытая библиотека для проигрывателя Adobe Flash, которая включает
    поддержку звуковых систем, иначе неподдерживаемых.
    * сначала пытается определить Esound, * Затем, пытается
    определить систему как OSS.
    Если ничто из вышеперечисленного не удается, она производит откат к драйверу ALSA, уже встроенному в FlashPlayer 9.

    Flashplugin-installer у нее в зависимостях, так что, если у вас не Esound и не OSS устанавливать надо именно flashplugin-installer.
    Это раз.
    Flashplugin-installer устанавливает устаревший NPAPI plugin, который не работает в браузерах на основе хромиума. Поэтому устанавливать лучше pepperflashplugin-nonfree и к нему browser-plugin-freshplayer-pepperflash для браузеров не поддерживающих PPAPI плагины.
    Это два.

  11. Если мне не изменяет память, это первый рецепт в комментариях.
    Третий рецепт — это установить google chrome, в котором есть pepperflash plugin, который выковыривает pepperflashplugin-nonfree.
    Кстати flashplugin-installer загружает плагин с сайта адоба.
    Чисто из любопытства — зачем вам потребовалась поддержка Esound и OSS? Я не долгожитель в линуксе и не встречал дистрибутива с их использованием.

  12. На мой взгляд NPAPI flashplugin нужен только в 32-х битных установках.

  13. Serg B, ответ на Ваш вопрос — в эпиграфе. И во вводных абзацах. Так уж случилось, что заходил я на несколько ресурсов, с которых неслись стоны и неподдержке флеши в линуксе вообще и в убунтоидах в особенности.
    Я взял и набрал первое, что пришло в голову (что описано в заметке). После чего все предметы стонов у меня заработали. Если бы не заработали, я дал бы менее строгий критерий поиска, и фильтровал бы больше базара, только и всего. И докопался бы до всех остальных предложенных вариантов.
    А так, по жизни, мне эта флеш, как и Esound и OSS, не нужны. Просто уилило, что люди четыре года обсуждают проблему, решаемую набором нескольких команд и просмотром их вывода.
    Ну а то, что я это решил прикрутить к делу при фильтрации музхлама — чистая лирика.
    Не нужно смешивать автора и его лирического героя :)

  14. Ну, Adobe Flash Plug-in работает даже в 64-битной FreeBSD 10.3 внутри нативного Firefox. И в этом нет ничего удивительного. Просто неохота запускать.

  15. Да, уилительно.
    Так пусть будет еще один ресурс, где это доходчиво разъяснено.
    Кстати, по запросу Antergos вы в гугле на третьем месте.

Оставить комментарий

Перейти к верхней панели