Betsy и я…

Клемент Лефевр aka clem
Перевод Алексея Федорчука
Оригинал: Betsy and I…

Релиз Betsy даётся мне тяжело, требуя в последнее время всего внимания. Я неделями слышу, как разработчики говорят о разных классных штуках, получил свою реализацию нескольких панелей, mtwebster развивает текущие версии Cinnamon, а я разглагольствую о своих критических ошибках… Если честно, во время подготовки этого релиза я чувствую себя одиноким и подавленным.. Я знаю по опыту, что это пройдёт… Если бы всё было легко — это не было бы так интересно. И сейчас ошибки исправлены (хотя я мог не все из них заметить), и Betsy готова «войти в распахнутые двери».

Как всякое большое дело, Betsy становилась красивее и красивее, стройнее и стройнее, и ошибки исчезали пачками. Процедура QA убила большинство из оставшихся, но также выявила, насколько они разные — Betsy и Rebecca.

Основа Linux Mint возникла в 2006 году, и недавнее, с версии 17, решение использовать LTS позволило нам сосредоточиться на собственных улучшениях без кардинальных изменений последней. Со временем Betsy, несомненно, даст нам такой же фундамент для LMDE, но сейчас это совершенно новый дистрибутив и, как таковой, требует внимания в рамках нашего проекта Linux Mint.

Наш цикл выпуска для LMDE чрезвычайно гибок, так что мы можем не зацикливаться на деталях, а сосредоточиться на важнейших для выхода Betsy вопросах. Пока мы отложили следующие вещи:

  • Установщик: шифрование домашнего каталога;
  • Установщик: локализация слайд-шоу;
  • Live-режим: извлечение носителя по завершении сеанса;
  • MATE: интеграция с Compiz;
  • Caja: падение после первого запуска и автоматический повтор запусков (кажется, происходит только в Virtualbox).

Со временем всё это будет сделано, но мы выпустим Бетси без этих фич, они станут доступны как обычный апгрейд или в виде новых образов.

Многие ошибки были исправлены, и со временем мы доберёмся до всех. Некоторые из этих ошибок весьма критичны, хотя лишь немногие из них трудно исправимы (я потратил весь минувший вторник на libpam-systemd, и не у меня нет полной уверенности ни в том, что я всё исправил, ни в том, что смогу сделать это для libpam-gnome-keyring сегодня):

  • Критично: fstab иногда некорректен сразу после установки;
  • Критично: запуск libpam-systemd приводит к противоречиям;
  • Критично: добавление libpam-systemd при его отсутствии не позволяет зайти на https://github.com/linuxmint/mdm/issues/92;
  • применять Gtk из 17.x;
  • в диалоге выбора файлов в Gtk остаётся слишком много вертикального пространства между элементами на боковой панели;
  • исчезла текстовая тема plymouth;
  • Mintlocale не показывает флаги.

Ранее на этой неделе была исправлена критическая ошибка в plymouth (на многих компьютерах система не загружалась без отмены опций quiet splash). Из оставшихся очень важно исправить первые три ошибки. Вопрос с fstab должен быть решён относительно легко. Проблема с libpam-systemd вызывает сбой или зависание приложения, работающего с повышенными привилегиями. Это одна из самых плохих ошибок, которые я видел за время работы с Linux, она имеет место быть во всех дистрибутивах, была пофиксена в Mint, частично — в LMDE 1, а также исправлена в апстриме systemd. Однако пока мы все ещё встречаемся с коллизиями, что не есть хорошо. Проблема с libpam-gnome-keyring вроде бы проста — но делает невозможным вход (и это может быть важнее, чем что-либо иное.

Конечно, мы всё это исправим и, надеюсь, это не займёт слишком много времени. Если вы хотите следить за развитием событий, заходите в раздел LMDE на GitHub’е.

Также не стесняйтесь заходить в #linuxmint-dev на irc.spotchat.org, где я выражаю свои эмоции, задаю вопросы, или просто делюсь своими достижениями.

Оставить комментарий

Перейти к верхней панели